Deutschsprachiges NOF - Forum

Support und Tutorials rund um das Thema NetObjects Fusion

collapse

* Wichtige Mitglieder-Information

Aufgrund der anstehenden gesetzlichen Änderungen in Sachen Datenschutz habe ich am 03.05.2018 eine umfassende Bereinigung unserer Datenbanken vorgenommen.

Bei dieser Bereinigung habe ich alle personenbezogenen und privaten Daten unserer Mitglieder aus den Mitglieder- , Beitrags- und Nachrichtendatenbanken gelöscht.

Konkret von der Löschung betroffen waren hierbei im Wesentlichen folgende Daten:

persönliche Avatare
E-Mail-Adressen
Angaben zum Wohnort
Angaben zum Geschlecht
Angaben zu Alter und Geburtstag
IP-Adressen
Websites und Websitetitel
Signaturen
Angaben zu diversen Messengern
Passwörter
Sicherheitsfragen und -antworten
Angaben zur verwendeten Programmversion
Angaben zum verwendeten Betriebssystem
sämtlicher persönlicher Schriftverkehr in Form privater Nachrichten

Beste Grüße nettesekel

* Friendship

DER Katzenblog – mit tollen Tipps und Ideen für deine Katze(n) <3

Die letzten Beiträge

Autor Thema: SwissKnife Kontakt Formular verschickt keine E-Mail  (Gelesen 4465 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline eisbaer.muc

  • Neuling
  • *
  • Beiträge: 20
SwissKnife Kontakt Formular verschickt keine E-Mail
« am: 27. Oktober 2015, 19:00:21 »
Hallo,

gemeinde.
Ich benutze NOF 12 und habe Windows 10.

Das  SwissKnife Kontakt Formular habe ich erfolgreich bei meiner Webseite eingebaut.
Nun habe ich versucht es genau so bei einer anderen Seite einzubauen. Leider geht das nicht, er bringt mir beim Senden keine Fehlermeldung aber er sendet auch nicht die Daten aus dem Formular.
Ich habe satt der kontakt.php eine anfrage.php bei der Aktion eingegeben. Da ich schon ein Kontakt Formular mit kontakt.php benutze, was leider auch nicht geht.

Ich will gern das  SwissKnife Kontakt Formular auf zwei seiten Benutzen.
Könnt Ihr mir Helfen?

Was benötigt ihr um den Fehler zu finden?
MfG Lars

*Danke im Voraus für die Hilfe*

Offline eisbaer.muc

  • Neuling
  • *
  • Beiträge: 20
Re: SwissKnife Kontakt Formular verschickt keine E-Mail
« Antwort #1 am: 28. Oktober 2015, 09:32:28 »
Nachtrag:

Wenn ich die Daten eingeben und auf Versenden klick, öffnet er das Kontaktformular neu und alle Daten sind weg. Er versendet nix und es kommt auch nicht das Danke fenster.

Ihr könnt es euch ja mal anschauen.

http://test.office-arbeit.de/Kontakt/kontakt.php

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
Re: SwissKnife Kontakt Formular verschickt keine E-Mail
« Antwort #2 am: 28. Oktober 2015, 11:45:12 »
Bin im Moment verhindert, ich schaus mir an, sobald ich Zeit habe. :)

Schau mal, ob dir das zwischenzeitlich weiterhilft: http://www.nof-community.de/formulare-mit-netobjects-fusion-und-swissknife-secure-form/swissknife-securecontactform-verschiedene-formulare-in-einem-projekt/

Offline eisbaer.muc

  • Neuling
  • *
  • Beiträge: 20
Re: SwissKnife Kontakt Formular verschickt keine E-Mail
« Antwort #3 am: 28. Oktober 2015, 17:28:40 »
Hallo,

das habe ich schon gefunden aber leider kein Erfolg.
Kann es sein weil ich FRams eingesetzt habe das es dann nicht geht?
Oder kann es sein weil ich es in einem Unterordner meines Server die Homepage hochlade?

MfG Lars
« Letzte Änderung: 28. Oktober 2015, 17:31:46 von eisbaer.muc »

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
Re: SwissKnife Kontakt Formular verschickt keine E-Mail
« Antwort #4 am: 28. Oktober 2015, 17:44:14 »
Kann es sein weil ich FRams eingesetzt habe das es dann nicht geht?

Absolut! Die solltest du raus nehmen, aus vielen Gründen.

Offline eisbaer.muc

  • Neuling
  • *
  • Beiträge: 20
Re: SwissKnife Kontakt Formular verschickt keine E-Mail
« Antwort #5 am: 28. Oktober 2015, 18:38:57 »
HAllo,

ok ich habe sie raus genommen aber mein Problem besteht immer noch?! (cry)

MfG Lars

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
Re: SwissKnife Kontakt Formular verschickt keine E-Mail
« Antwort #6 am: 29. Oktober 2015, 12:22:28 »
Dein Testlink ist gestorben...  (cry)

Offline eisbaer.muc

  • Neuling
  • *
  • Beiträge: 20

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
Re: SwissKnife Kontakt Formular verschickt keine E-Mail
« Antwort #8 am: 29. Oktober 2015, 14:42:02 »
kannst du mir die skn_mail.php und die check_token.php mal zukommen lassen? am besten zippen weil php kannst du hier nicht anhängen. :)

Offline eisbaer.muc

  • Neuling
  • *
  • Beiträge: 20
Re: SwissKnife Kontakt Formular verschickt keine E-Mail
« Antwort #9 am: 29. Oktober 2015, 17:23:25 »
Hallo,

Datei im Anhang.

mfg Lars




***edit nettesekel***Dateianhang zur Sicherheit des TE entfernt***
« Letzte Änderung: 29. Oktober 2015, 18:41:49 von nettesekel »

Offline Gerd

  • Junior Mitglied
  • **
  • Beiträge: 47
Re: SwissKnife Kontakt Formular verschickt keine E-Mail
« Antwort #10 am: 29. Oktober 2015, 18:05:52 »
Hallo nettesekel,

was muss ich ändern wenn ich zwei Formularvorlagen auf einer Webseite verwenden will. Ich brauch ja zwei skn und alles doppelt, aber was ändert man? Vielleicht kannst Du mir kurz helfen.

Gruß Gerd

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
« Letzte Änderung: 29. Oktober 2015, 18:38:56 von nettesekel »

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
Re: SwissKnife Kontakt Formular verschickt keine E-Mail
« Antwort #12 am: 29. Oktober 2015, 18:29:22 »
Einen Fehler habe ich bereits gefunden. Vielleicht wars das ja schon. In der check_token.php findet sich dieser Abschnitt

Code: PHP
  1. echo '<script type="text/javascript">window.location = "./kontakt.php"</script>';

da sollte deine buchungsservice.php auftauchen statt der kontakt.php
« Letzte Änderung: 29. Oktober 2015, 18:39:21 von nettesekel »

Offline eisbaer.muc

  • Neuling
  • *
  • Beiträge: 20
Re: SwissKnife Kontakt Formular verschickt keine E-Mail
« Antwort #13 am: 29. Oktober 2015, 18:50:16 »
Habe es geändert, brachte aber keinen Erfolg  :-(
Wo kann der Fehler noch sein?

Gruß

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
Re: SwissKnife Kontakt Formular verschickt keine E-Mail
« Antwort #14 am: 29. Oktober 2015, 19:05:45 »
Du hast die Datei aber auch auf dem Server ausgetauscht und deinen Browsercache gelöscht!?

Außerdem sieht es so aus, als ob die in der skn_mail.php includierte skn_smtp_Buchung.php nicht im Ordner scripts auf dem Server liegt.
« Letzte Änderung: 29. Oktober 2015, 19:10:29 von nettesekel »

Deutschsprachiges NOF - Forum

Support und Tutorials rund um das Thema NetObjects Fusion