Deutschsprachiges NOF - Forum

Support und Tutorials rund um das Thema NetObjects Fusion

collapse

* Alles hat ein Ende...

Eine Weisheit der Dakota-Indianer sagt:
"Wenn Du entdeckst, dass Du ein totes Pferd reitest, steig ab!"

Vor fast fünf Jahren habe ich die NOF-Community gegründet und nachdem just zu diesem Zeitpunkt das „alte NOF-Forum“ quasi über Nacht vom Betreiber geschlossen wurde, war mein Forum für viele Nutzer von NetObjects Fusion eine willkommene Alternative.

Inzwischen sind weit über 5000 NetObjects-Nutzer in der NOF-Community registriert und täglich kommen weitere hinzu. An interessierten Mitgliedern fehlt es also nicht. Was aber fehlt, sind Mitglieder, die Lust haben, anderen Nutzern bei der Lösung ihrer vielfältigen Probleme in der Anwendung von NetObjects Fusion zu helfen. Vielleicht, weil viele von ihnen - ebenso wie ich - das Interesse an NOF verloren haben und zwischenzeitlich mit anderen Programmen arbeiten.

Aktuell ist es so, dass der Support wie die Kosten für den Betrieb der NOF-Community fast ausschließlich von mir übernommen werden. Dies, und die Tatsache, dass ich die Arbeit mit NetObjects Fusion nicht mehr für zeitgemäß halte, veranlasst mich, den aktiven Forenbetrieb zu beenden. Die Beiträge, Tipps und Anleitungen aus den letzten Jahren stehen ab heute nur noch als Nachschlagewerk zur Verfügung.

Ich bedanke mich an dieser Stelle ganz herzlich bei allen, die mich und die NOF-Community in den vergangenen Jahren unterstützt haben.

Beste Grüße nettesekel

Die letzten Beiträge

Autor Thema: Navigationsleiste nicht sichtbar  (Gelesen 3104 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Pinnacle

  • Neuling
  • *
  • Beiträge: 6
  • NOF-Version: NOF 13
  • System: Windows 8.1
Navigationsleiste nicht sichtbar
« am: 08. Januar 2016, 20:37:44 »
Hallo,
ich arbeite noch nicht sehr lange mit NOF und habe nun eine neue Homepage erstellt. Ich habe die Style-Vorlagen von NOF verwendet. Leider ist die Navigationsleiste nicht bzw kaum zu sehen. Wenn man mit der Maus über die entsprechenden Stellen fährt, ist das Wort lesbar, aber das sieht so furchtbar aus.
Einmal hat es beim Publizieren über den InternetExplorer schon funktioniert, jetzt hab ich über Firefox publiziert und es ist wieder alles weg. Kann das sein? Gibt es da eine Lösung?

Offline Tao

  • Profi Mitglied
  • *****
  • Beiträge: 505
Re: Navigationsleiste nicht sichtbar
« Antwort #1 am: 08. Januar 2016, 22:47:41 »
Hallo Pinnacle!

Ohne hier irgendwie oder irgendwo etwas davon zu sehen was du meinst, kann man nur Vermutungen anstellen.

Styles gibt es viele, Buttons auch, Farbkombinationen ebenso.

Am besten wäre wenn du dein Projekt auf einen Testserver oder in ein Testverzeichnis laden würdest und uns den Link dazu nennen würdest.

LG Tao

Offline Pinnacle

  • Neuling
  • *
  • Beiträge: 6
  • NOF-Version: NOF 13
  • System: Windows 8.1
Re: Navigationsleiste nicht sichtbar
« Antwort #2 am: 09. Januar 2016, 07:13:17 »
Hallo Tao, vielen Dank, dass du mir deine Hilfe anbietest. Testserver usw sagt mir leider nichts. Hier ist der Link zur Homepage:
http://www.christian-maar-schule.de

Offline Tao

  • Profi Mitglied
  • *****
  • Beiträge: 505
Re: Navigationsleiste nicht sichtbar
« Antwort #3 am: 09. Januar 2016, 09:22:55 »
Guten Morgen!

Nachdem du die Seite schon auf einer Domain online hast, braucht es auch keinen Testserver mehr.

Ich habe gerade eben die Seiten angesehen. Die Navi selbst ist vorhanden, allerdings sind der überwiegende Teil der Buttons vollständig transparent und ohne generierte Schrift darauf. Den Bookmark-Style kenne ich eigentlich als unproblematisch. Er macht ja auch von Hause aus teiltransparente Buttons.
Jetzt kann ich, ohne dein Projekt direkt bei mir auf dem Rechner zu haben nur, allgemeine Hinweise, bzw. Fragen geben.

Hast du für die NOF 13 Version das Service-Update 5 installiert?
Startest du dein NOF als Administrator?
Ist deine Java-Version auf dem Rechner halbwegs aktuell?
Welche Einstellungen hast du in den NOF-Optionen für die Grafik-Ausgabe (für PNG / JPG / GIF) eingestellt?

Am allerliebsten wäre mir wenn du von deinem Projekt eine ZIP-Vorlagendatei machen würdest und ich mir das direkt bei mir auf dem Rechner ansehen könnte.

LG Tao

« Letzte Änderung: 09. Januar 2016, 09:40:08 von Tao »

Offline mangray

  • Junior Mitglied
  • **
  • Beiträge: 46
    • Personensuche mit Hunden
  • NOF-Version: NOF 11
  • System: Windows 7
  • System-Typ: 32bit
Re: Navigationsleiste nicht sichtbar
« Antwort #4 am: 09. Januar 2016, 11:43:04 »
Ich weiß nicht ob schon etwas geändert wurde aber bei mir
schaut die Navigation tadellos aus!
Mit FF, Chrom und IE getestet!

nice day
mangray
Wissen kann man lernen,
            Weisheit ist die Essenz
            der Erfahrung

mangray

Offline Pinnacle

  • Neuling
  • *
  • Beiträge: 6
  • NOF-Version: NOF 13
  • System: Windows 8.1
Re: Navigationsleiste nicht sichtbar
« Antwort #5 am: 09. Januar 2016, 12:06:43 »
Vielen Dank,
ja, jetzt gehts. Welche Änderung genau zum richtigen Ergebnis geführt hat, weiß ich nicht. Ich hab bei der Navigationsleiste nochmals den Style bestimmt (heißt Bookmark bei NOF) und mit Internetexplorer statt Firefox publiziert.
Virlen Dank für eure Rückmeldungen!

Offline Pinnacle

  • Neuling
  • *
  • Beiträge: 6
  • NOF-Version: NOF 13
  • System: Windows 8.1
Re: Navigationsleiste nicht sichtbar
« Antwort #6 am: 09. Januar 2016, 18:15:26 »
Jetzt hab ich die Seite mit ein paar kleinen Inhaltsänderungen noch,al hochgeladen und es funktioniert wieder nicht mehr. Könnt ihr bitte nochmal schauen?
Es sind zwei große Fehler: zum einen ist die Navigationsleiste nur zu erahnen, zum anderen sind auf der Seite "Formulare" die grünen Buttons (eigentlich nur Vierecke mit Text drauf) schwarz.
Ich habe NOF13
@ Tao: Das mit dem Update weiß ich nicht, kann ich das irgendwo nachschauen?
Nein, Java ist nicht aktuell, das macht dauernd Probleme beim virenscan
Wie mache ich das kit der zip-Vorlagendatei für dich? Bin da sehr unbedarft.
Vielen Dank schon ml für alle Hilfe!

Offline Tao

  • Profi Mitglied
  • *****
  • Beiträge: 505
Re: Navigationsleiste nicht sichtbar
« Antwort #7 am: 10. Januar 2016, 10:45:17 »
Habe jetzt nochmals deine Seiten angesehen, die Navi schein mir aber soweit vollkommen ok zu sein. Alle Beschriftungen sind gut lesbar. Einzig die Liste "Aus den Klassen" ist eindeutig zu lang und mit der Länge der Aufklappmenüs schluckt der Hintergrund die etwas kontrastschwachen Buttons dann ein wenig.

Schaue bitte in das Hilfe-Menü von NOF, der unterste Punkt "Über NetObjects Fusion 2013" gibt dir Auskunft über den aktuellen Softwarestand von deiner Version. Hier sollte bei Version folgenden Zahl stehen: 13.00.0000.5580.
Ist die hinterste Zahl nicht 5580 sondern kleiner, solltest du dir das letzte NOF-Update mit der Nummer #5 von der Hersteller-Seite Herunterladen und installieren. Wichtig, die Installation unbedingt "als Administrator" ausführen.
Das Update findest du hier: http://netobjects.de/html/downloads.html

Danach solltest du dir unbedingt auch die aktuelle Java-Version installieren.

Hast du alles aktuell stellst du in NOF die automatisch generierte Bildausgabe für alle drei Dateitypen (JPG /GIF / PNG) jeweils auf "nicht optimiert" ein.
Dazu gehst du ins NOF-Menü
Werkzeuge ->
Optionen ->
Anwendung ->
Bei Automatisch generierte Bildausgabe wählst du der Reihe nach alle drei Dateitypen aus du stellst jeden auf "Nicht optimiert".

Im gleichen Dialogfeld, gleich unter der Bildausgabe, kannst du auch noch sehen ob dein NOF auch die wirklich aktuelle (die gerade eben installierte Version) von Java verwendet.

Wenn du das alles gemacht hast, publizierst du nochmals deine gesamte Seite neu und nimmst im Publizieren-Dialogfeld das Häkchen bei "Nur veränderte Assets publizieren" raus. Diese Option kannst du später wieder aktivieren.

Im anhängenden Screenshot sind alle obigen Einstellungen zu sehen.

***edit***Änderung auf Wunsch von Tao vorgenommen***nettesekel***
« Letzte Änderung: 11. Januar 2016, 23:02:41 von nettesekel »

Offline mangray

  • Junior Mitglied
  • **
  • Beiträge: 46
    • Personensuche mit Hunden
  • NOF-Version: NOF 11
  • System: Windows 7
  • System-Typ: 32bit
Re: Navigationsleiste nicht sichtbar
« Antwort #8 am: 10. Januar 2016, 11:50:07 »
Schaut noch immer gut aus  :)

nice day
mangray
Wissen kann man lernen,
            Weisheit ist die Essenz
            der Erfahrung

mangray

Offline Pinnacle

  • Neuling
  • *
  • Beiträge: 6
  • NOF-Version: NOF 13
  • System: Windows 8.1
Re: Navigationsleiste nicht sichtbar
« Antwort #9 am: 10. Januar 2016, 13:47:38 »

Ja, es schaut wieder richtig aus, weil ich jedes Mal den Browser für die Publizierung ändere. Mal IE, mal FF, mal Chrome. Dadurch klappt es jetzt. Aber das kann ja keine Dauerlösung sein.


Danke für die genaue Anleitung. Genau so brauch ich das. Echt super.
Ich werd es morgen probieren, heute schaff ich es nicht mehr und mich dann wieder melden. Danke nochmal!

Offline Tao

  • Profi Mitglied
  • *****
  • Beiträge: 505
Re: Navigationsleiste nicht sichtbar
« Antwort #10 am: 10. Januar 2016, 14:05:25 »
Versteh ich jetzt nicht wirklich.
Für die öffentliche Publizierung auf den Webserver brauchst du doch den Browser gar nicht. Das wird per FTP auf deinen Server geladen. Ganz ohne Browser.

Offline Pinnacle

  • Neuling
  • *
  • Beiträge: 6
  • NOF-Version: NOF 13
  • System: Windows 8.1
Re: Navigationsleiste nicht sichtbar
« Antwort #11 am: 11. Januar 2016, 20:02:14 »
Hallo Tao,
keine Ahnung, warum das so war, aber es war der einzieg Trick, der funktionierte.
Jetzt hab ich alle deine Tipps beherzigt (nochmals vielen Dank für die genaue Anleitung und den Screenshot, echt super!) und das publizieren hat funktioniert.
Vielen Dank!

Offline Tao

  • Profi Mitglied
  • *****
  • Beiträge: 505
Re: Navigationsleiste nicht sichtbar
« Antwort #12 am: 11. Januar 2016, 20:08:47 »
Aber immer gerne doch.   ;-)

Deutschsprachiges NOF - Forum

Support und Tutorials rund um das Thema NetObjects Fusion