Deutschsprachiges NOF - Forum

Support und Tutorials rund um das Thema NetObjects Fusion

collapse

* Alles hat ein Ende...

April 2017

Eine Weisheit der Dakota-Indianer sagt:
"Wenn Du entdeckst, dass Du ein totes Pferd reitest, steig ab!"

Vor fast fünf Jahren habe ich die NOF-Community gegründet und nachdem just zu diesem Zeitpunkt das „alte NOF-Forum“ quasi über Nacht vom Betreiber geschlossen wurde, war mein Forum für viele Nutzer von NetObjects Fusion eine willkommene Alternative.

Inzwischen sind weit über 5000 NetObjects-Nutzer in der NOF-Community registriert und täglich kommen weitere hinzu. An interessierten Mitgliedern fehlt es also nicht. Was aber fehlt, sind Mitglieder, die Lust haben, anderen Nutzern bei der Lösung ihrer vielfältigen Probleme in der Anwendung von NetObjects Fusion zu helfen. Vielleicht, weil viele von ihnen - ebenso wie ich - das Interesse an NOF verloren haben und zwischenzeitlich mit anderen Programmen arbeiten.

Aktuell ist es so, dass der Support wie die Kosten für den Betrieb der NOF-Community fast ausschließlich von mir übernommen werden. Dies, und die Tatsache, dass ich die Arbeit mit NetObjects Fusion nicht mehr für zeitgemäß halte, veranlasst mich, den aktiven Forenbetrieb zu beenden. Die Beiträge, Tipps und Anleitungen aus den letzten Jahren stehen ab heute nur noch als Nachschlagewerk zur Verfügung.

Ich bedanke mich an dieser Stelle ganz herzlich bei allen, die mich und die NOF-Community in den vergangenen Jahren unterstützt haben.

Beste Grüße nettesekel

Die letzten Beiträge

Absturz bei FTP Publizierung
von nettesekel
16. April 2017, 12:51:56

E-Masil Adresse herausfinden
von nettesekel
11. April 2017, 16:16:20

Keine Neuinstallation möglich
von nettesekel
10. April 2017, 16:00:27

Publizieren geht nicht
von musikavokale
09. April 2017, 23:15:50

NOF 15
von nettesekel
04. April 2017, 23:55:26

Feststehender Seitenbereich
von nettesekel
01. April 2017, 17:37:12

Aufklappbare Navigation
von nettesekel
31. März 2017, 12:50:30

Nov 12 zum hare ausreisen
von Jim Panse
26. März 2017, 11:48:03

Lytebox Dateiablage
von fahrzeugseiten
21. März 2017, 23:23:23

* Schatznasen Feed

* Aquablogger Feed

* Strickzeugs Feed

* Links für Katzenfreunde

* ...

Fachanwalt für Internet-Recht C.Schmietenknop

* Friendship

DER Katzenblog – mit tollen Tipps und Ideen für deine Katze(n) <3

Autor Thema: Hintergrund nicht farbig  (Gelesen 4212 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline cc

  • Senior Mitglied
  • ****
  • Beiträge: 289
Hintergrund nicht farbig
« am: 05. März 2014, 16:29:13 »
Liebe NOF Helfer,
ich habe eine Tabelle erstellt und den Hintergrund rot hinterlegt,
aber - an einer Stelle erscheint die Spalte nur teilweise rot.

Schrift linksbündig ausgereichtet - links rot, rechts wird es wie der Seitenhintergrund
Schrift mittig ausgerichtet - Hintergrund wie der Seitenhintergrund, also creme

Tabellenspalteneigenschaften habe ich aber rot markiert

woran kann das liegen dass die gesamte Spalte nicht rot erscheint ?

Hier noch der Link zum Problem, am Seitenende:
http://www.communicanis.de/html/seminar_anbieten.html

Danke für Tips.

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
    • Aquablogger der Aquaristikblog
Re: Hintergrund nicht farbig
« Antwort #1 am: 05. März 2014, 16:42:49 »
Ich nehme an du meinst die äußere linke Spalte in der letzten Tabelle am Seitenende!?

Die texte hast du dort von Hand zentriert und zwar nicht über die Zelleneigenschaften, sondern über die Texteigenschaften und der Zelle mit dem Bild hast du keine Hintergrundfarbe zugewiesen.
« Letzte Änderung: 05. März 2014, 17:04:03 von nettesekel »

Offline cc

  • Senior Mitglied
  • ****
  • Beiträge: 289
Re: Hintergrund nicht farbig
« Antwort #2 am: 05. März 2014, 16:53:21 »
die äussere rechte Spalte war gemeint

ich habe Tabelleneigenschaften Hintergrund rot gewählt
und Tabellenspalten Eigenschaften ebenso

Danke schon mal. Gabriele

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
    • Aquablogger der Aquaristikblog
Re: Hintergrund nicht farbig
« Antwort #3 am: 05. März 2014, 17:13:52 »
Ja, ich meinte die Rechte Spalte...
 
Dein Quellcode sagt aber etwas Anderes:

Hier die erste Zelle mit dem Inhalt "Ihr Ansprechpartner"
Im zellen-Tag steht die Hintergrundfarbe, im p-Tag auch nochmal und text-align: center; sorgt für den zentrierten Text.
Code: HTML5
  1. <TD ROWSPAN="7" VALIGN="TOP" WIDTH="198" STYLE="background-color: rgb(128,0,0);" ID="Zelle18293">
  2.   <P STYLE="font-size: 11px; color: rgb(255,255,204); text-decoration: none ; text-align: center; background-color: rgb(128,0,0); margin-bottom: 0px;">Ihr Ansprechpartner....
  3.  


Hier die Zelle mit dem Bild. Die einzige Styleeigenschaft die hier für die Zelle eingetragen ist ist die Zentrierte Ausrichtung ALIGN="center" sonst steht da nichts.
Code: HTML5
  1. <TD ALIGN="center"><A HREF="../html/wer.html#dc"><IMG ID="Bild5254" HEIGHT="90" WIDTH="135" SRC="../assets/images/autogen/dc_02.jpg" BORDER="0"></A></TD>
                       

Offline cc

  • Senior Mitglied
  • ****
  • Beiträge: 289
Re: Hintergrund nicht farbig
« Antwort #4 am: 05. März 2014, 17:23:00 »
Was soll ich denn jetzt machen ?

Liegt es vielleicht daran, dass es sich um verbundene Zellen handelt ?
« Letzte Änderung: 05. März 2014, 17:41:34 von cc »

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
    • Aquablogger der Aquaristikblog
Re: Hintergrund nicht farbig
« Antwort #5 am: 05. März 2014, 17:43:31 »
Klick mal die Tabelle an und stelle für die ganze Tabelle die Hintergrundfarbe so ein.

Offline cc

  • Senior Mitglied
  • ****
  • Beiträge: 289
Re: Hintergrund nicht farbig
« Antwort #6 am: 05. März 2014, 17:45:49 »
das habe ich gemacht

- Tabelle angeklickt
- Tabelle Eigenschaften Hintergrund rot

ändert aber leider nichts

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
    • Aquablogger der Aquaristikblog
Re: Hintergrund nicht farbig
« Antwort #7 am: 05. März 2014, 17:49:15 »
Was hast du denn da für einen Specialeffekt... kannst du mal eine Vorlage von der einen Seite machen?

Offline cc

  • Senior Mitglied
  • ****
  • Beiträge: 289
Re: Hintergrund nicht farbig
« Antwort #8 am: 05. März 2014, 17:52:10 »
Specialeffekt ???
Uiuiu - nicht bewusst.....

Vorlage erstelle ich schicke sie wohin ?

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
    • Aquablogger der Aquaristikblog
Re: Hintergrund nicht farbig
« Antwort #9 am: 05. März 2014, 18:28:29 »
Ich hab schon reingesehen... dein Projekt hat da echt einen totalen Knall.
Sobald du das Bild aus der Zelle nimmst, ist die Zelle rot. Fügst du das Bild wieder ein, dann wird die Zelle links und Rechts vom Bild scheinbar gelb. Tut sie aber gar nicht. Das was da gelb ist, ist eine Tabelle die NOF einfach um das Bild drumherum legt. Und die Breite dieser Tabelle stellt NOF dummer Weise auch noch auf 100%. Sprich diese von NOF erstellte, in der Arbeitsansicht nicht sichtbare Tabelle macht sich genau so Breit wie die Spalte in welcher sich das Bild befindet.

Code: HTML5
  1. <TD ROWSPAN="5" WIDTH="179" CLASS="Problemzelle" STYLE="background-color: rgb(128,0,0);"
  2.  
  3. ID="Zelle18311">
  4.     <TABLE WIDTH="100%" BORDER="0" CELLSPACING="0" CELLPADDING="0">
  5.         <TR>
  6.             <TD ALIGN="center"><IMG ID="Bild5254" HEIGHT="90" WIDTH="135" SRC="file:///C:/Users/Lutz Eich/Documents/NetObjects Fusion 12.0/User
  7. Sites/communicanis/Preview/Autogen/dc_02.jpg" BORDER="0"></TD>
  8.         </TR>
  9.     </TABLE>
  10. </TD>

Wäre NOF jetzt so nett gewesen und hätte dieser Zelle eine ID verpasst, dann könnten wir das Aussehen dieser Tabelle über die ID steuern, aber NOF macht keine halben Sachen. Diese Tabelle hat keine ID.
Das Ganze Elend kommt m.E.  daher, dass du diese Seite mal in einer recht alten NOF-Version begonnen hast und von Version zu Version hast du wahrscheinlich irgendwelche Fehler mirgeschleppt. Warum das nun so aussieht, kann ich also erklären, wie man es beheben kann... dazu habe ich ausser, dass man den Quellcode der Seite nachträglich im Editor bearbeiten kann im Moment noch keinen Plan. Muss mal gucken...

Offline cc

  • Senior Mitglied
  • ****
  • Beiträge: 289
Re: Hintergrund nicht farbig
« Antwort #10 am: 05. März 2014, 18:32:50 »
Danke für die ganze Mühe. So ein Elend.
Ich kann doch nicht die ganze seite neu...
nee, aber dass da ein fehler mitwandert, von Version zu Version, das war zu befürchten,
weil immer wieder mal so unerklärliche Phänomene auftreten.
Vielleicht findet sich eine Lösung, abwarten, es eilt ja nicht, dann eben teilcreme.
Danke !!

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
    • Aquablogger der Aquaristikblog
Re: Hintergrund nicht farbig
« Antwort #11 am: 05. März 2014, 18:34:34 »
Nein... Moment... ich habe da was im QT deiner Seite gefunden... muss mal gucken, ob das in meiner Vorlage auch drin ist.
« Letzte Änderung: 05. März 2014, 18:43:15 von nettesekel »

Offline nettesekel

  • Administrator
  • *****
  • Beiträge: 8181
    • Aquablogger der Aquaristikblog
Re: Hintergrund nicht farbig
« Antwort #12 am: 05. März 2014, 19:03:52 »
Ich glaube, das kriegen wir behoben. Ursächlich ist die völlig falsche Einbindung des Formulars oberhalb der Tabelle und einige damit verbundene Style-Angaben. Das was ich dir jetzt beschreibe, machst du an einer Kopie der Seite und testetst dann erstmal ob dein Formuar noch geht. Wenn ja, kannst du mit dem neuen Projekt weiter arbeiten.

Also... du doppelklickst zuerst in die durchgehende Zelle unterhalb des grünen Pfeils. Die Zeile hat links außen ein kleines Symbol.
Wenn der Cursor blinkt gehst du oben in der Menüleiste auf Text >> HTML bearbeiten...

Es öffnet sich ein Fenster, in welchem sich der von dir eingebundene Code befindet. Diesen Code müssen wir nun auteilen. Am besten öffnest du dir parallel deinen Editor.

Der Code beginnt mit den folgenden Zeilen, welche du löschen wirst:
Code: HTML5
  1. <meta http-equiv="Content-Language" content="de">
  2. <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
  3. <meta name="generator" content="Formular-Maker" Version="1.6.6">
  4. <title>SEMINARINTERESSE</title>


------------------------------------------------------------------------------------------------

Dann folgt dieser Bereich, achte bitte genaustens auf Anfang und Ende. Schneide den Bereich aus und füge in erstmal im Editor ein:

Code: HTML5
  1. <style type="text/css">
  2.  
  3.   body {background-color:#FFFFCC; font-family:"Verdana";}
  4.  
  5.   label.myForm {font-family:"Verdana"; font-size:9pt;width:362;}
  6.  
  7.   h1.farbig {color:#FFFFCC; font-family:"Verdana"; font-size:9pt;}
  8.  
  9.   tr {background-color:#FFFFCC; font-family:"Verdana"; font-size:9pt;}
  10.  
  11.   .td {background-color:#FFFFCC; font-family:"Verdana"; font-size:9pt;}
  12.  
  13.   .button {background-color:#FFFFCC; font-family:"Verdana"; font-size:9pt;}
  14.  
  15.   p.farbig {color:#000000; font-family:"Verdana"; font-size:9pt;}
  16.  
  17.   p.anno {color:#000000; font-family:"Verdana"; font-size:9pt;}
  18.   .feld {background-color: #FFFFCC;color: #000000;border-style:groove; border-width:1px;font-family:"Verdana";font-size:9pt; width:100%;}
  19.  
  20. <script language=javaScript><!--
  21. function checkSenderMail(){
  22. if(document.SEMINARINTERESSE.SenderMail.value.length==0)
  23.    return false;
  24.  for(i=0;i<document.SEMINARINTERESSE.SenderMail.value.length;i++){
  25.    if((document.SEMINARINTERESSE.SenderMail.value.charAt(i)<"-") ||
  26.      (document.SEMINARINTERESSE.SenderMail.value.charAt(i)=="/") ||
  27.      ((document.SEMINARINTERESSE.SenderMail.value.charAt(i)>"9") && (document.SEMINARINTERESSE.SenderMail.value.charAt(i)<"@")) ||
  28.      ((document.SEMINARINTERESSE.SenderMail.value.charAt(i)>"Z") && (document.SEMINARINTERESSE.SenderMail.value.charAt(i)<"a") && (document.SEMINARINTERESSE.SenderMail.value.charAt(i)!="_")) ||
  29.      (document.SEMINARINTERESSE.SenderMail.value.charAt(i)>"z") ||
  30.      (document.SEMINARINTERESSE.SenderMail.value.indexOf('@')==-1) ||
  31.      (document.SEMINARINTERESSE.SenderMail.value.indexOf('.')==-1) ){
  32.        return false;
  33.    }
  34.  }
  35.  return true;
  36. }
  37.  function chkFormular()
  38.   {
  39.           if(window.document.SEMINARINTERESSE.Name.value == "")  {
  40.             alert("Ihr Name ?");
  41.             document.SEMINARINTERESSE.Name.focus();
  42.             return false;
  43.             }
  44.            if(!checkSenderMail()){
  45.      alert("Bitte eine gültige E-Mail-Adresse eingeben");
  46.      document.SEMINARINTERESSE.SenderMail.focus();
  47.      return false;
  48. }
  49.           if(window.document.SEMINARINTERESSE.Seminarinteresse.value == "")  {
  50.             alert("welches Seminar stellen Sie sich vor ?");
  51.             document.SEMINARINTERESSE.Seminarinteresse.focus();
  52.             return false;
  53.             }
  54.   }
  55. //--></script>

------------------------------------------------------------------------------------------------

Nun kommen wieder einige Zeilen, die gelöscht werden müssen:

Code: HTML5
  1. </head>
  2. <body style="background-image:url(#FFFFCC)">
  3. <div align="left">
  4. <h1 class="farbig">SEMINARINTERESSE</h1>

------------------------------------------------------------------------------------------------

Scrolle ans Ende des Codes und lösche dort nun auch noch diese Zeilen:
Code: HTML5
  1. </div>
  2. </body>
  3. </html>


Alles was jetzt noch im Fenster steht, bleibt dort stehen und du klickst nur noch unten rechts auf OK um die Änderung zu speichern.

-----------------------------------------------------------------------------------------------------

Nun geht es an den Code im Editor.

Hier suchst du nun nacheinander alle Zeilen, die ich im Anschluss poste und löschst diese.

Code: HTML5
  1.   body {background-color:#FFFFCC; font-family:"Verdana";}

Code: HTML5
  1.   h1.farbig {color:#FFFFCC; font-family:"Verdana"; font-size:9pt;}
  2.  
  3.   tr {background-color:#FFFFCC; font-family:"Verdana"; font-size:9pt;}
  4.  
  5.   .td {background-color:#FFFFCC; font-family:"Verdana"; font-size:9pt;}

----------------------------------------------------------------------------------------------------

Den übrigen Code kopierst du in deine Zwischenablage, klickst in deiner Seite einmal ins Layout, so dass die Layouteigenschaften auf der EP zu sehen sind und klickst dann den HTML-Button auf der EP.
Es öffnet sich wieder ein Fenster und du klickst oben am Rand auf das zweite Symbol. Dort wo nun der Cursor blinkt, fügst du den Code aus deiner Zwischenablage ein. Mit OK bestätigen und nach erneuter Publizierung sollten die Probleme aus der Welt sein. Teste aber bitte dein Formular.

Rückmeldung wäre schön.

« Letzte Änderung: 05. März 2014, 19:06:03 von nettesekel »

Offline cc

  • Senior Mitglied
  • ****
  • Beiträge: 289
Re: Hintergrund nicht farbig
« Antwort #13 am: 06. März 2014, 10:10:11 »
Guten Morgen / Tag,
ich komme erst jetzt dazu, an der Seite zu arbeiten.
Zunächst mal habe ich einfach das Formular entfernt um zu schauen, ob es klappt:
ja, dann erscheint die untere Tabelle gesamt Hintergrund rot.

Die Frage ist:
wie kann ich denn auf Dauer die Formulare  fehlerfrei einbauen, damit das nicht mehr passiert ?
Es gibt noch diverse andere Formulare, Seminaranmeldung, Feedback etc.
und vor allem: das Formular bleibt ja nicht so, sondern ändert sich, sei es durch neue Termine oder neue Seminarangebote.
Dann würde der gleiche Fehler auftreten ?

Dann ein grosses Dankeschön für die Arbeit, die Du Dir gemacht hast.

Ich habe alles umgesetzt:
http://www.communicanis.de/html/test_sa.html
roter Hintergrund funktioniert
Schriftgrösse des Formulares hat sich verändert.

Gabriele
« Letzte Änderung: 06. März 2014, 10:31:00 von cc »

Offline cc

  • Senior Mitglied
  • ****
  • Beiträge: 289
Re: Hintergrund nicht farbig
« Antwort #14 am: 06. März 2014, 10:38:12 »
Formular aktualisiert - gleicher Fehler wieder wie zuvor.

neues textfeld erstellt und 'Ansprechpartner' aus der vorhandenen Tabelle rausgenommen: gleicher Fehler, Hintergrund nur teilweise rot.

Deutschsprachiges NOF - Forum

Support und Tutorials rund um das Thema NetObjects Fusion